OCSF Application Activity Schema
The Application Activity class captures application-level events and operations, including web application requests, API calls, database queries, email activities, file sharing operations, and other application-specific events. This schema is part of the OCSF (Open Cybersecurity Schema Framework) standard. For general OCSF guidance and field naming conventions, see OCSF Schema Overview.
For more information on the OCSF Version 1.2 standard, see OCSF v1.2 Documentation.
Note: For OCSF schema fields, array indexes start at array[1] and not array[0].
| Field | Description | Value Type |
|---|---|---|
| action | Optional: The normalized caption of 'action_id' or the source-specific action. | string |
| action_id | Required: The normalized action taken by a control or other policy-based system leading to an outcome or disposition. | integer |
| activity_id | Required: The normalized identifier of the activity that triggered the event. | integer |
| activity_name | Optional: The event activity name, as defined by the activity_id. | string |
| actor | Required: The actor that performed the activity on the target file. | object |
| actor.app_uid | Optional: The unique identifier of the client application or service that initiated the activity. | string |
| actor.idp | Optional: This object describes details about the Identity Provider used. | object |
| actor.idp.name | Recommended: The name of the identity provider. | string |
| actor.idp.uid | Recommended: The unique identifier of the identity provider. | string |
| actor.invoked_by | Optional: The name of the service that invoked the activity as described in the event. | string |
| actor.process | Recommended: The process that initiated the activity. | object |
| actor.process.cmd_line | Recommended: The full command line used to launch an application, service, process, or job. | string |
| actor.process.container | Recommended: The information describing an instance of a container. | object |
| actor.process.container.hash | Recommended: Commit hash of image created for docker or the SHA256 hash of the container. For example: 13550340a8681c84c861.... |
object |
| actor.process.container.hash.algorithm | Optional: The hash algorithm used to create the digital fingerprint, normalized to the caption of 'algorithm_id'. | string |
| actor.process.container.hash.algorithm_id | Required: The identifier of the normalized hash algorithm, which was used to create the digital fingerprint. | integer |
| actor.process.container.hash.value | Required: The digital fingerprint value. | string |
| actor.process.container.image | Recommended: The container image used as a template to run the container. | object |
| actor.process.container.image.name | Recommended: The image name. For example: elixir. |
string |
| actor.process.container.image.uid | Required: The unique image ID. For example: 77af4d6b9913. |
string |
| actor.process.container.name | Recommended: The container name. | string |
| actor.process.container.size | Recommended: The size of the container image. | long |
| actor.process.container.uid | Recommended: The full container unique identifier for this instantiation of the container. For example: ac2ea168264a08f9aaca0dfc82ff.... |
string |
| actor.process.created_time | Recommended: The time when the process was created/started. | long |
| actor.process.file | Recommended: The process file object. | object |
| actor.process.file.data_classification | Recommended: The Data Classification object includes information about data classification levels and data category types. | object |
| actor.process.file.data_classification.category_id | Recommended: The normalized identifier of the data classification category. | integer |
| actor.process.file.data_classification.confidentiality_id | Recommended: The normalized identifier of the file content confidentiality indicator. | integer |
| actor.process.file.hashes | Recommended: An array of hash attributes. | array of objects |
| actor.process.file.hashes.algorithm | Optional: The hash algorithm used to create the digital fingerprint, normalized to the caption of 'algorithm_id'. | string |
| actor.process.file.hashes.algorithm_id | Required: The identifier of the normalized hash algorithm, which was used to create the digital fingerprint. | integer |
| actor.process.file.hashes.value | Required: The digital fingerprint value. | string |
| actor.process.file.name | Required: The name of the file. | string |
| actor.process.file.parent_folder | Optional: The parent folder in which the file resides. | string |
| actor.process.file.path | Recommended: The full path to the file. . | string |
| actor.process.file.size | Optional: The size of data, in bytes. | long |
| actor.process.file.type | Optional: The file type. | string |
| actor.process.file.type_id | Required: The file type ID. | integer |
| actor.process.integrity | Optional: The process integrity level, normalized to the caption of the direction_id value. In the case of 'Other', it is defined by the event source (Windows only). | string |
| actor.process.integrity_id | Optional: The normalized identifier of the process integrity level (Windows only). | integer |
| actor.process.name | Recommended: The friendly name of the process, for example: Notepad++. |
string |
| actor.process.namespace_pid | Recommended: If running under a process namespace (such as in a container), the process identifier within that process namespace. | integer |
| actor.process.parent_process | Recommended: The parent process of this process object. | object |
| actor.process.parent_process.cmd_line | Recommended: The full command line used to launch an application, service, process, or job. | string |
| actor.process.parent_process.container | Recommended: The information describing an instance of a container. | object |
| actor.process.parent_process.container.hash | Recommended: Commit hash of image created for docker or the SHA256 hash of the container. For example: 13550340a8681c84c861aac2e5.... |
object |
| actor.process.parent_process.container.hash.algorithm_id | Required: The identifier of the normalized hash algorithm, which was used to create the digital fingerprint. | integer |
| actor.process.parent_process.container.hash.value | Required: The digital fingerprint value. | string |
| actor.process.parent_process.container.image | Recommended: The container image used as a template to run the container. | object |
| actor.process.parent_process.container.image.name | Recommended: The image name. For example: elixir. |
string |
| actor.process.parent_process.container.image.uid | Required: The unique image ID. For example: 77af4d6b9913. |
string |
| actor.process.parent_process.container.name | Recommended: The container name. | string |
| actor.process.parent_process.container.size | Recommended: The size of the container image. | long |
| actor.process.parent_process.container.uid | Recommended: The full container unique identifier for this instantiation of the container. For example: ac2ea168264a08f9aaca0df.... |
string |
| actor.process.parent_process.created_time | Recommended: The time when the process was created/started. | long |
| actor.process.parent_process.file | Recommended: The process file object. | object |
| actor.process.parent_process.file.data_classification | Recommended: The Data Classification object includes information about data classification levels and data category types. | object |
| actor.process.parent_process.file.data_classification.category_id | Recommended: The normalized identifier of the data classification category. | integer |
| actor.process.parent_process.file.data_classification.confidentiality_id | Recommended: The normalized identifier of the file content confidentiality indicator. | integer |
| actor.process.parent_process.file.hashes | Recommended: An array of hash attributes. | array of objects |
| actor.process.parent_process.file.hashes.algorithm_id | Required: The identifier of the normalized hash algorithm, which was used to create the digital fingerprint. | integer |
| actor.process.parent_process.file.hashes.value | Required: The digital fingerprint value. | string |
| actor.process.parent_process.file.name | Required: The name of the file. | string |
| actor.process.parent_process.file.path | Recommended: The full path to the file. | string |
| actor.process.parent_process.file.type | Optional: The file type. | string |
| actor.process.parent_process.file.type_id | Required: The file type ID. | integer |
| actor.process.parent_process.integrity | Optional: The process integrity level, normalized to the caption of the direction_id value. In the case of 'Other', it is defined by the event source (Windows only). | string |
| actor.process.parent_process.integrity_id | Optional: The normalized identifier of the process integrity level (Windows only). | integer |
| actor.process.parent_process.name | Recommended: The friendly name of the process, for example: Notepad++. |
string |
| actor.process.parent_process.namespace_pid | Recommended: If running under a process namespace (such as in a container), the process identifier within that process namespace. | integer |
| actor.process.parent_process.parent_process | Recommended: The parent process of this process object. | object |
| actor.process.parent_process.parent_process.cmd_line | Recommended: The full command line used to launch an application, service, process, or job. | string |
| actor.process.parent_process.parent_process.container | Recommended: The information describing an instance of a container. | object |
| actor.process.parent_process.parent_process.container.hash | Recommended: Commit hash of image created for docker or the SHA256 hash of the container. For example: 13550340a8681c84c861aac2.... |
object |
| actor.process.parent_process.parent_process.container.hash.algorithm_id | Required: The identifier of the normalized hash algorithm, which was used to create the digital fingerprint. | integer |
| actor.process.parent_process.parent_process.container.hash.value | Required: The digital fingerprint value. | string |
| actor.process.parent_process.parent_process.container.image | Recommended: The container image used as a template to run the container. | object |
| actor.process.parent_process.parent_process.container.image.name | Recommended: The image name. For example: elixir. |
string |
| actor.process.parent_process.parent_process.container.image.uid | Required: The unique image ID. For example: 77af4d6b9913. |
string |
| actor.process.parent_process.parent_process.container.name | Recommended: The container name. | string |
| actor.process.parent_process.parent_process.container.size | Recommended: The size of the container image. | long |
| actor.process.parent_process.parent_process.container.uid | Recommended: The full container unique identifier for this instantiation of the container. For example: ac2ea168264a08f9aaca0dfc.... |
string |
| actor.process.parent_process.parent_process.created_time | Recommended: The time when the process was created/started. | long |
| actor.process.parent_process.parent_process.file | Recommended: The process file object. | object |
| actor.process.parent_process.parent_process.file.data_classification | Recommended: The Data Classification object includes information about data classification levels and data category types. | object |
| actor.process.parent_process.parent_process.file.data_classification.category_id | Recommended: The normalized identifier of the data classification category. | integer |
| actor.process.parent_process.parent_process.file.data_classification.confidentiality_id | Recommended: The normalized identifier of the file content confidentiality indicator. | integer |
| actor.process.parent_process.parent_process.file.hashes | Recommended: An array of hash attributes. | array of objects |
| actor.process.parent_process.parent_process.file.hashes.algorithm_id | Required: The identifier of the normalized hash algorithm, which was used to create the digital fingerprint. | integer |
| actor.process.parent_process.parent_process.file.hashes.value | Required: The digital fingerprint value. | string |
| actor.process.parent_process.parent_process.file.name | Required: The name of the file. | string |
| actor.process.parent_process.parent_process.file.path | Recommended: The full path to the file. | string |
| actor.process.parent_process.parent_process.file.type_id | Required: The file type ID. | integer |
| actor.process.parent_process.parent_process.name | Recommended: The friendly name of the process, for example: Notepad++. |
string |
| actor.process.parent_process.parent_process.namespace_pid | Recommended: If running under a process namespace (such as in a container), the process identifier within that process namespace. | integer |
| actor.process.parent_process.parent_process.pid | Recommended: The process identifier, as reported by the operating system. | integer |
| actor.process.parent_process.parent_process.uid | Recommended: A unique identifier for this process assigned by the producer (tool). | string |
| actor.process.parent_process.parent_process.user | Recommended: The user under which this process is running. | object |
| actor.process.parent_process.parent_process.user.name | Recommended: The username. For example, janedoe1. |
string |
| actor.process.parent_process.parent_process.user.type_id | Recommended: The account type identifier. | integer |
| actor.process.parent_process.parent_process.user.uid | Recommended: The unique user identifier. | string |
| actor.process.parent_process.pid | Recommended: The process identifier, as reported by the operating system. | integer |
| actor.process.parent_process.session | Optional: The user session under which this process is running. | object |
| actor.process.parent_process.session.created_time | Recommended: The time when the session was created. | long |
| actor.process.parent_process.session.is_remote | Recommended: The indication of whether the session is remote. | boolean |
| actor.process.parent_process.session.issuer | Recommended: The identifier of the session issuer. | string |
| actor.process.parent_process.session.uid | Recommended: The unique identifier of the session. | string |
| actor.process.parent_process.uid | Recommended: A unique identifier for this process assigned by the producer (tool). | string |
| actor.process.parent_process.user | Recommended: The user under which this process is running. | object |
| actor.process.parent_process.user.domain | Optional: The domain where the user is defined. For example: the LDAP or Active Directory domain. | string |
| actor.process.parent_process.user.name | Recommended: The username. For example, janedoe1. |
string |
| actor.process.parent_process.user.type_id | Recommended: The account type identifier. | integer |
| actor.process.parent_process.user.uid | Recommended: The unique user identifier. | string |
| actor.process.pid | Recommended: The process identifier, as reported by the operating system. | integer |
| actor.process.session | Optional: The user session under which this process is running. | object |
| actor.process.session.created_time | Recommended: The time when the session was created. | long |
| actor.process.session.is_remote | Recommended: The indication of whether the session is remote. | boolean |
| actor.process.session.issuer | Recommended: The identifier of the session issuer. | string |
| actor.process.session.uid | Recommended: The unique identifier of the session. | string |
| actor.process.session.uuid | Optional: The universally unique identifier of the session. | string |
| actor.process.uid | Recommended: A unique identifier for this process assigned by the producer (tool). | string |
| actor.process.user | Recommended: The user under which this process is running. | object |
| actor.process.user.account | Optional: The user's account or the account associated with the user. | object |
| actor.process.user.account.name | Recommended: The name of the account (For example, GCP Account Name). | string |
| actor.process.user.account.type | Optional: The account type, normalized to the caption of 'account_type_id'. | string |
| actor.process.user.account.type_id | Recommended: The normalized account type identifier. | integer |
| actor.process.user.account.uid | Recommended: The unique identifier of the account (For example, AWS Account ID). | string |
| actor.process.user.domain | Optional: The domain where the user is defined. For example: the LDAP or Active Directory domain. | string |
| actor.process.user.email_addr | Optional: The user's primary email address. | string |
| actor.process.user.full_name | Optional: The full name of the person, as per the LDAP Common Name attribute (cn). | string |
| actor.process.user.name | Recommended: The username. For example, janedoe1. |
string |
| actor.process.user.org | Optional: Organization and org unit related to the user. | object |
| actor.process.user.org.name | Recommended: The name of the organization. For example, Widget, Inc. | string |
| actor.process.user.org.ou_name | Recommended: The name of the organizational unit, within an organization. For example, Finance, IT, R&D | string |
| actor.process.user.org.uid | Recommended: The unique identifier of the organization. For example, its Active Directory or AWS Org ID. | string |
| actor.process.user.risk_level | Optional: The risk level, normalized to the caption of the risk_level_id value. | string |
| actor.process.user.type | Optional: The type of the user. For example, System, AWS IAM User, | string |
| actor.process.user.type_id | Recommended: The account type identifier. | integer |
| actor.process.user.uid | Recommended: The unique user identifier. | string |
| actor.session | Optional: The user session from which the activity was initiated. | object |
| actor.session.created_time | Recommended: The time when the session was created. | long |
| actor.session.is_remote | Recommended: The indication of whether the session is remote. | boolean |
| actor.session.issuer | Recommended: The identifier of the session issuer. | string |
| actor.session.uid | Recommended: The unique identifier of the session. | string |
| actor.session.uuid | Optional: The universally unique identifier of the session. | string |
| actor.user | Recommended: The user that initiated the activity or the user context from which the activity was initiated. | object |
| actor.user.account | Optional: The user's account or the account associated with the user. | object |
| actor.user.account.name | Recommended: The name of the account (For example, GCP Account Name). | string |
| actor.user.account.type | Optional: The account type, normalized to the caption of 'account_type_id'. | string |
| actor.user.account.type_id | Recommended: The normalized account type identifier. | integer |
| actor.user.account.uid | Recommended: The unique identifier of the account (For example, AWS Account ID). | string |
| actor.user.domain | Optional: The domain where the user is defined. For example: the LDAP or Active Directory domain. | string |
| actor.user.email_addr | Optional: The user's primary email address. | string |
| actor.user.full_name | Optional: The full name of the person, as per the LDAP Common Name attribute (cn). | string |
| actor.user.name | Recommended: The username. For example, janedoe1. |
string |
| actor.user.org | Optional: Organization and org unit related to the user. | object |
| actor.user.org.name | Recommended: The name of the organization. For example, Widget, Inc. | string |
| actor.user.org.ou_name | Recommended: The name of the organizational unit, within an organization. For example, Finance, IT, R&D | string |
| actor.user.org.uid | Recommended: The unique identifier of the organization. For example, its Active Directory or AWS Org ID. | string |
| actor.user.risk_level | Optional: The risk level, normalized to the caption of the risk_level_id value. | string |
| actor.user.type | Optional: The type of the user. For example, System, AWS IAM User, | string |
| actor.user.type_id | Recommended: The account type identifier. | integer |
| actor.user.uid | Recommended: The unique user identifier. | string |
| api | Optional: Describes details about a typical API (Application Programming Interface) call. | object |
| api.operation | Required: Verb/Operation associated with the request | string |
| api.request | Recommended: Details pertaining to the API request. | object |
| api.request.uid | Required: The unique request identifier. | string |
| api.response | Recommended: Details pertaining to the API response. | object |
| api.response.code | Recommended: The numeric response sent to a request. | integer |
| api.response.error | Recommended: Error Code | string |
| api.response.error_message | Recommended: Error Message | string |
| api.response.message | Recommended: The description of the event/finding, as defined by the source. | string |
| api.service | Optional: The information pertaining to the API service. | object |
| api.service.name | Recommended: The name of the service. | string |
| api.service.uid | Recommended: The unique identifier of the service. | string |
| api.service.version | Recommended: The version of the service. | string |
| app | Required: The application that was affected by the lifecycle event. This also applies to self-updating application systems. | object |
| app.data_classification | Recommended: The Data Classification object includes information about data classification levels and data category types. | object |
| app.data_classification.category_id | Recommended: The normalized identifier of the data classification category. | integer |
| app.data_classification.confidentiality_id | Recommended: The normalized identifier of the file content confidentiality indicator. | integer |
| app.feature | Optional: The feature that reported the event. | object |
| app.feature.name | Recommended: The name of the feature. | string |
| app.feature.uid | Recommended: The unique identifier of the feature. | string |
| app.feature.version | Recommended: The version of the feature. | string |
| app.name | Recommended: The name of the product. | string |
| app.uid | Recommended: The unique identifier of the product. | string |
| app.vendor_name | Required: The name of the vendor of the product. | string |
| app.version | Recommended: The version of the product, as defined by the event source. For example: 2013.1.3-beta. |
string |
| category_name | Optional: The event category name, as defined by category_uid value. | string |
| category_uid | Required: The category unique identifier of the event. | integer |
| class_name | Optional: The event class name, as defined by the class_uid. | string |
| class_uid | Required: The unique identifier of a class. A class describes the attributes available in an event. | integer |
| cloud | Required: Describes details about the Cloud environment where the event was originally created or logged. | object |
| cloud.account | Optional: The account object describes details about the account that was the source or target of the activity. | object |
| cloud.account.name | Recommended: The name of the account (For example, GCP Account Name). | string |
| cloud.account.type | Optional: The account type, normalized to the caption of 'account_type_id'. | string |
| cloud.account.type_id | Recommended: The normalized account type identifier. | integer |
| cloud.account.uid | Recommended: The unique identifier of the account (For example, AWS Account ID). | string |
| cloud.org | Optional: Organization and org unit relevant to the event or object. | object |
| cloud.org.name | Recommended: The name of the organization. For example, Widget, Inc. | string |
| cloud.org.ou_name | Recommended: The name of the organizational unit, within an organization. For example, Finance, IT, R&D | string |
| cloud.org.uid | Recommended: The unique identifier of the organization. For example, its Active Directory or AWS Org ID. | string |
| cloud.provider | Required: The unique name of the Cloud services provider, such as AWS, MS Azure, GCP, | string |
| cloud.region | Recommended: The name of the cloud region, as defined by the cloud provider. | string |
| command_uid | Recommended: The command identifier that is associated with this scan event. This ID uniquely identifies the proactive scan command, For example, , if remotely initiated. | string |
| connection_info | Optional: The network connection information. | object |
| connection_info.direction | Optional: The direction of the initiated connection, traffic, or email, normalized to the caption of the direction_id value. | string |
| connection_info.direction_id | Required: The normalized identifier of the direction of the initiated connection, traffic, or email. | integer |
| connection_info.protocol_name | Optional: The TCP/IP protocol name in lowercase, as defined by the Internet Assigned Numbers Authority (IANA). . | string |
| connection_info.protocol_num | Recommended: The TCP/IP protocol number, as defined by the Internet Assigned Numbers Authority (IANA). | integer |
| connection_info.session | Optional: The authenticated user or service session. | object |
| connection_info.session.created_time | Recommended: The time when the session was created. | long |
| connection_info.session.is_remote | Recommended: The indication of whether the session is remote. | boolean |
| connection_info.session.issuer | Recommended: The identifier of the session issuer. | string |
| connection_info.session.uid | Recommended: The unique identifier of the session. | string |
| connection_info.session.uuid | Optional: The universally unique identifier of the session. | string |
| connection_info.uid | Optional: The unique identifier of the connection. | string |
| count | Optional: The number of times that events in the same logical group occurred during the event Start Time to End Time period. | integer |
| database | Recommended: The database object is used for databases which are typically datastore services that contain an organized collection of structured and unstructured data or a types of data. | object |
| database.data_classification | Recommended: The Data Classification object includes information about data classification levels and data category types. | object |
| database.data_classification.category_id | Recommended: The normalized identifier of the data classification category. | integer |
| database.data_classification.confidentiality_id | Recommended: The normalized identifier of the file content confidentiality indicator. | integer |
| database.name | Recommended: The database name, ordinarily as assigned by a database administrator. | string |
| database.type | Recommended: The database type. | string |
| database.type_id | Required: The normalized identifier of the database type. | integer |
| database.uid | Recommended: The unique identifier of the database. | string |
| databucket | Recommended: The data bucket object is a basic container that holds data, typically organized through the use of data partitions. | object |
| databucket.data_classification | Recommended: The Data Classification object includes information about data classification levels and data category types. | object |
| databucket.data_classification.category_id | Recommended: The normalized identifier of the data classification category. | integer |
| databucket.data_classification.confidentiality_id | Recommended: The normalized identifier of the file content confidentiality indicator. | integer |
| databucket.name | Recommended: The databucket name. | string |
| databucket.type | Recommended: The databucket type. | string |
| databucket.type_id | Required: The normalized identifier of the databucket type. | integer |
| databucket.uid | Recommended: The unique identifier of the databucket. | string |
| device | Recommended: An addressable device, computer system or host. | object |
| device.container | Recommended: The information describing an instance of a container. | object |
| device.container.hash | Recommended: Commit hash of image created for docker or the SHA256 hash of the container. For example: 13550340a8681c84c861aac2e.... |
object |
| device.container.hash.algorithm | Optional: The hash algorithm used to create the digital fingerprint, normalized to the caption of 'algorithm_id'. | string |
| device.container.hash.algorithm_id | Required: The identifier of the normalized hash algorithm, which was used to create the digital fingerprint. | integer |
| device.container.hash.value | Required: The digital fingerprint value. | string |
| device.container.image | Recommended: The container image used as a template to run the container. | object |
| device.container.image.name | Recommended: The image name. For example: elixir. |
string |
| device.container.image.uid | Required: The unique image ID. For example: 77af4d6b9913. |
string |
| device.container.name | Recommended: The container name. | string |
| device.container.size | Recommended: The size of the container image. | long |
| device.container.uid | Recommended: The full container unique identifier for this instantiation of the container. For example: ac2ea168264a08f9aaca0.... |
string |
| device.domain | Optional: The network domain where the device resides. For example: work.example.com. |
string |
| device.groups | Optional: The group names to which the device belongs. For example: ["Windows Laptops", "Engineering"]. |
array of objects |
| device.groups.desc | Optional: The group description. | string |
| device.groups.domain | Optional: The domain where the group is defined. For example: the LDAP or Active Directory domain. | string |
| device.groups.name | Recommended: The group name. | string |
| device.groups.type | Optional: The type of the group or account. | string |
| device.groups.uid | Recommended: The unique identifier of the group. For example, for Windows events this is the security identifier (SID) of the group. | string |
| device.hostname | Recommended: The device hostname. | string |
| device.instance_uid | Recommended: The unique identifier of a VM instance. | string |
| device.interface_name | Recommended: The name of the network interface (For example, eth2). | string |
| device.interface_uid | Recommended: The unique identifier of the network interface. | string |
| device.ip | Recommended: The device IP address, in either IPv4 or IPv6 format. | string |
| device.is_compliant | Optional: The event occurred on a compliant device. | boolean |
| device.is_managed | Optional: The event occurred on a managed device. | boolean |
| device.name | Recommended: The alternate device name, ordinarily as assigned by an administrator. Name could be any other string that helps to identify the device, such as a phone number. | string |
| device.namespace_pid | Recommended: If running under a process namespace (such as in a container), the process identifier within that process namespace. | integer |
| device.os | Optional: The endpoint operating system. | object |
| device.os.name | Required: The operating system name. | string |
| device.os.type | Optional: The type of the operating system. | string |
| device.os.type_id | Required: The type identifier of the operating system. | integer |
| device.owner | Recommended: The identity of the service or user account that owns the endpoint or was last logged into it. | object |
| device.owner.account | Optional: The user's account or the account associated with the user. | object |
| device.owner.account.name | Recommended: The name of the account (For example, GCP Account Name). | string |
| device.owner.account.type | Optional: The account type, normalized to the caption of 'account_type_id'. | string |
| device.owner.account.type_id | Recommended: The normalized account type identifier. | integer |
| device.owner.account.uid | Recommended: The unique identifier of the account (For example, AWS Account ID). | string |
| device.owner.domain | Optional: The domain where the user is defined. For example: the LDAP or Active Directory domain. | string |
| device.owner.email_addr | Optional: The user's primary email address. | string |
| device.owner.full_name | Optional: The full name of the person, as per the LDAP Common Name attribute (cn). | string |
| device.owner.name | Recommended: The username. For example, janedoe1. |
string |
| device.owner.org | Optional: Organization and org unit related to the user. | object |
| device.owner.org.name | Recommended: The name of the organization. For example, Widget, Inc. | string |
| device.owner.org.ou_name | Recommended: The name of the organizational unit, within an organization. For example, Finance, IT, R&D | string |
| device.owner.org.uid | Recommended: The unique identifier of the organization. For example, its Active Directory or AWS Org ID. | string |
| device.owner.risk_level | Optional: The risk level, normalized to the caption of the risk_level_id value. | string |
| device.owner.type | Optional: The type of the user. For example, System, AWS IAM User, | string |
| device.owner.type_id | Recommended: The account type identifier. | integer |
| device.owner.uid | Recommended: The unique user identifier. | string |
| device.region | Recommended: The region where the virtual machine is located. For example, an AWS Region. | string |
| device.type | Optional: The device type. | string |
| device.type_id | Required: The device type ID. | integer |
| device.uid | Recommended: The unique identifier of the device. For example the Windows TargetSID or AWS EC2 ARN. | string |
| dst_endpoint | Recommended: The endpoint that received the activity on the target file. | object |
| dst_endpoint.container | Recommended: The information describing an instance of a container. | object |
| dst_endpoint.container.hash | Recommended: Commit hash of image created for docker or the SHA256 hash of the container. For example: 13550340a8681c84c861aac2e5.... |
object |
| dst_endpoint.container.hash.algorithm | Optional: The hash algorithm used to create the digital fingerprint, normalized to the caption of 'algorithm_id'. | string |
| dst_endpoint.container.hash.algorithm_id | Required: The identifier of the normalized hash algorithm, which was used to create the digital fingerprint. | integer |
| dst_endpoint.container.hash.value | Required: The digital fingerprint value. | string |
| dst_endpoint.container.image | Recommended: The container image used as a template to run the container. | object |
| dst_endpoint.container.image.name | Recommended: The image name. For example: elixir. |
string |
| dst_endpoint.container.image.uid | Required: The unique image ID. For example: 77af4d6b9913. |
string |
| dst_endpoint.container.name | Recommended: The container name. | string |
| dst_endpoint.container.size | Recommended: The size of the container image. | long |
| dst_endpoint.container.uid | Recommended: The full container unique identifier for this instantiation of the container. | string |
| dst_endpoint.domain | Optional: The name of the domain. | string |
| dst_endpoint.hostname | Recommended: The fully qualified name of the endpoint. | string |
| dst_endpoint.instance_uid | Recommended: The unique identifier of a VM instance. | string |
| dst_endpoint.interface_name | Recommended: The name of the network interface. | string |
| dst_endpoint.interface_uid | Recommended: The unique identifier of the network interface. | string |
| dst_endpoint.ip | Recommended: The IP address of the endpoint, in either IPv4 or IPv6 format. | string |
| dst_endpoint.location | Optional: The geographical location of the endpoint. | object |
| dst_endpoint.location.city | Recommended: The name of the city. | string |
| dst_endpoint.location.continent | Recommended: The name of the continent. | string |
| dst_endpoint.location.country | Recommended: The ISO 3166-1 Alpha-2 country code. The two letter country code should be capitalized. | string |
| dst_endpoint.location.lat | Optional: The geographical Latitude coordinate represented in Decimal Degrees (DD). | float |
| dst_endpoint.location.long | Optional: The geographical Longitude coordinate represented in Decimal Degrees (DD). | float |
| dst_endpoint.location.region | Optional: The alphanumeric code that identifies the principal subdivision of the country. | string |
| dst_endpoint.mac | Optional: The Media Access Control (MAC) address of the endpoint. | string |
| dst_endpoint.name | Recommended: The short name of the endpoint. | string |
| dst_endpoint.namespace_pid | Recommended: If running under a process namespace (such as in a container), the process identifier within that process namespace. | integer |
| dst_endpoint.owner | Recommended: The identity of the service or user account that owns the endpoint or was last logged into it. | object |
| dst_endpoint.owner.account | Optional: The user's account or the account associated with the user. | object |
| dst_endpoint.owner.account.name | Recommended: The name of the account (For example, GCP Account Name). | string |
| dst_endpoint.owner.account.type | Optional: The account type, normalized to the caption of 'account_type_id'. | string |
| dst_endpoint.owner.account.type_id | Recommended: The normalized account type identifier. | integer |
| dst_endpoint.owner.account.uid | Recommended: The unique identifier of the account (For example, AWS Account ID). | string |
| dst_endpoint.owner.domain | Optional: The domain where the user is defined. For example: the LDAP or Active Directory domain. | string |
| dst_endpoint.owner.email_addr | Optional: The user's primary email address. | string |
| dst_endpoint.owner.full_name | Optional: The full name of the person, as per the LDAP Common Name attribute (cn). | string |
| dst_endpoint.owner.name | Recommended: The username. For example, janedoe1. |
string |
| dst_endpoint.owner.org | Optional: Organization and org unit related to the user. | object |
| dst_endpoint.owner.org.name | Recommended: The name of the organization. For example, Widget, Inc. | string |
| dst_endpoint.owner.org.ou_name | Recommended: The name of the organizational unit, within an organization. For example, Finance, IT, R&D | string |
| dst_endpoint.owner.org.uid | Recommended: The unique identifier of the organization. For example, its Active Directory or AWS Org ID. | string |
| dst_endpoint.owner.risk_level | Optional: The risk level, normalized to the caption of the risk_level_id value. | string |
| dst_endpoint.owner.type | Optional: The type of the user. For example, System, AWS IAM User, | string |
| dst_endpoint.owner.type_id | Recommended: The account type identifier. | integer |
| dst_endpoint.owner.uid | Recommended: The unique user identifier. | string |
| dst_endpoint.port | Recommended: The port used for communication within the network connection. | integer |
| dst_endpoint.proxy_endpoint | Optional: The network proxy information pertaining to a specific endpoint. | object |
| dst_endpoint.proxy_endpoint.container | Recommended: The information describing an instance of a container. | object |
| dst_endpoint.proxy_endpoint.container.hash | Recommended: Commit hash of image created for docker or the SHA256 hash of the container. For example: 13550340a8681c84c861aac2.... |
object |
| dst_endpoint.proxy_endpoint.container.hash.algorithm | Optional: The hash algorithm used to create the digital fingerprint, normalized to the caption of 'algorithm_id'. | string |
| dst_endpoint.proxy_endpoint.container.hash.algorithm_id | Required: The identifier of the normalized hash algorithm, which was used to create the digital fingerprint. | integer |
| dst_endpoint.proxy_endpoint.container.hash.value | Required: The digital fingerprint value. | string |
| dst_endpoint.proxy_endpoint.container.image | Recommended: The container image used as a template to run the container. | object |
| dst_endpoint.proxy_endpoint.container.image.name | Recommended: The image name. For example: elixir. |
string |
| dst_endpoint.proxy_endpoint.container.image.uid | Required: The unique image ID. For example: 77af4d6b9913. |
string |
| dst_endpoint.proxy_endpoint.container.name | Recommended: The container name. | string |
| dst_endpoint.proxy_endpoint.container.size | Recommended: The size of the container image. | long |
| dst_endpoint.proxy_endpoint.container.uid | Recommended: The full container unique identifier for this instantiation of the container. For example: ac2ea168264a08f9aaca0dfc8.... |
string |
| dst_endpoint.proxy_endpoint.hostname | Recommended: The fully qualified name of the endpoint. | string |
| dst_endpoint.proxy_endpoint.instance_uid | Recommended: The unique identifier of a VM instance. | string |
| dst_endpoint.proxy_endpoint.interface_name | Recommended: The name of the network interface (For example, eth2). | string |
| dst_endpoint.proxy_endpoint.interface_uid | Recommended: The unique identifier of the network interface. | string |
| dst_endpoint.proxy_endpoint.ip | Recommended: The IP address of the endpoint, in either IPv4 or IPv6 format. | string |
| dst_endpoint.proxy_endpoint.name | Recommended: The short name of the endpoint. | string |
| dst_endpoint.proxy_endpoint.namespace_pid | Recommended: If running under a process namespace (such as in a container), the process identifier within that process namespace. | integer |
| dst_endpoint.proxy_endpoint.owner | Recommended: The identity of the service or user account that owns the endpoint or was last logged into it. | object |
| dst_endpoint.proxy_endpoint.owner.account | Optional: The user's account or the account associated with the user. | object |
| dst_endpoint.proxy_endpoint.owner.account.name | Recommended: The name of the account (For example, GCP Account Name). | string |
| dst_endpoint.proxy_endpoint.owner.account.type | Optional: The account type, normalized to the caption of 'account_type_id'. | string |
| dst_endpoint.proxy_endpoint.owner.account.type_id | Recommended: The normalized account type identifier. | integer |
| dst_endpoint.proxy_endpoint.owner.account.uid | Recommended: The unique identifier of the account (For example, AWS Account ID). | string |
| dst_endpoint.proxy_endpoint.owner.domain | Optional: The domain where the user is defined. For example: the LDAP or Active Directory domain. | string |
| dst_endpoint.proxy_endpoint.owner.email_addr | Optional: The user's primary email address. | string |
| dst_endpoint.proxy_endpoint.owner.full_name | Optional: The full name of the person, as per the LDAP Common Name attribute (cn). | string |
| dst_endpoint.proxy_endpoint.owner.name | Recommended: The username. For example, janedoe1. |
string |
| dst_endpoint.proxy_endpoint.owner.org | Optional: Organization and org unit related to the user. | object |
| dst_endpoint.proxy_endpoint.owner.org.name | Recommended: The name of the organization. For example, Widget, Inc. | string |
| dst_endpoint.proxy_endpoint.owner.org.ou_name | Recommended: The name of the organizational unit, within an organization. For example, Finance, IT, R&D | string |
| dst_endpoint.proxy_endpoint.owner.org.uid | Recommended: The unique identifier of the organization. For example, its Active Directory or AWS Org ID. | string |
| dst_endpoint.proxy_endpoint.owner.risk_level | Optional: The risk level, normalized to the caption of the risk_level_id value. | string |
| dst_endpoint.proxy_endpoint.owner.type | Optional: The type of the user. For example, System, AWS IAM User, | string |
| dst_endpoint.proxy_endpoint.owner.type_id | Recommended: The account type identifier. | integer |
| dst_endpoint.proxy_endpoint.owner.uid | Recommended: The unique user identifier. | string |
| dst_endpoint.proxy_endpoint.port | Recommended: The port used for communication within the network connection. | integer |
| dst_endpoint.proxy_endpoint.svc_name | Recommended: The service name in service-to-service connections. | string |
| dst_endpoint.proxy_endpoint.type_id | Recommended: The network endpoint type ID. | integer |
| dst_endpoint.proxy_endpoint.uid | Recommended: The unique identifier of the endpoint. | string |
| dst_endpoint.svc_name | Recommended: The service name in service-to-service connections. | string |
| dst_endpoint.type_id | Recommended: The network endpoint type ID. | integer |
| dst_endpoint.uid | Recommended: The unique identifier of the endpoint. | string |
| dst_endpoint.zone | Optional: The network zone or LAN segment. | string |
| duration | Recommended: The duration of the scan | integer |
| end_time | Optional: The end time of a time period, or the time of the most recent event included in the aggregate event. | long |
| event_seq_id | Required: The sequence identifier for the event. | long |
| event_size | Required: The size of the event in bytes. | long |
| event_time | Required: The normalized event occurrence time or the finding creation time. | long |
| file | Required: The file that is the target of the activity. | object |
| file.data_classification | Recommended: The Data Classification object includes information about data classification levels and data category types. | object |
| file.data_classification.category_id | Recommended: The normalized identifier of the data classification category. | integer |
| file.data_classification.confidentiality_id | Recommended: The normalized identifier of the file content confidentiality indicator. | integer |
| file.hashes | Recommended: An array of hash attributes. | array of objects |
| file.hashes.algorithm | Optional: The hash algorithm used to create the digital fingerprint, normalized to the caption of 'algorithm_id'. | string |
| file.hashes.algorithm_id | Required: The identifier of the normalized hash algorithm, which was used to create the digital fingerprint. | integer |
| file.hashes.value | Required: The digital fingerprint value. | string |
| file.name | Required: The name of the file. | string |
| file.parent_folder | Optional: The parent folder in which the file resides. | string |
| file.path | Recommended: The full path to the file. . | string |
| file.size | Optional: The size of data, in bytes. | long |
| file.type | Optional: The file type. | string |
| file.type_id | Required: The file type ID. | integer |
| http_request | Recommended: Details about the underlying http request. | object |
| http_request.http_headers | Recommended: Additional HTTP headers of an HTTP request or response. | array of objects |
| http_request.http_headers.name | Required: The name of the header | string |
| http_request.http_headers.value | Required: The value of the header | string |
| http_request.http_method | Optional: The HTTP request method indicates the desired action to be performed for a given resource. | string |
| http_request.length | Optional: The HTTP request length, in number of bytes. | integer |
| http_request.referrer | Optional: The request header that identifies the address of the previous web page, which is linked to the current web page or resource being requested. | string |
| http_request.uid | Optional: The unique identifier of the http request. | string |
| http_request.url | Recommended: The URL object that pertains to the request. | object |
| http_request.url.category_ids | Recommended: The Website categorization identifiers. | array of integers |
| http_request.url.hostname | Recommended: The URL host as extracted from the URL. . | string |
| http_request.url.path | Recommended: The URL path as extracted from the URL. | string |
| http_request.url.port | Recommended: The URL port. For example: 80. |
integer |
| http_request.url.query_string | Recommended: The query portion of the URL. | string |
| http_request.url.scheme | Recommended: The scheme portion of the URL. | string |
| http_request.url.url_string | Recommended: The URL string. See RFC 1738. | string |
| http_request.user_agent | Recommended: The request header that identifies the operating system and web browser. | string |
| http_request.version | Recommended: The Hypertext Transfer Protocol (HTTP) version. | string |
| http_response | Optional: Details about the HTTP response, if available. | object |
| http_response.code | Required: The Hypertext Transfer Protocol (HTTP) status code returned from the web server to the client. | integer |
| http_response.content_type | Optional: The request header that identifies the original media type of the resource (prior to any content encoding applied for sending). | string |
| http_response.http_headers | Recommended: Additional HTTP headers of an HTTP request or response. | array of objects |
| http_response.http_headers.name | Required: The name of the header | string |
| http_response.http_headers.value | Required: The value of the header | string |
| indexed_time | Required: The time when the event was indexed. | long |
| message | Recommended: The description of the event/finding, as defined by the source. | string |
| metadata | Required: The metadata associated with the event or a finding. | object |
| metadata.correlation_uid | Optional: The unique identifier used to correlate events. | string |
| metadata.data_classification | Recommended: The Data Classification object includes information about data classification levels and data category types. | object |
| metadata.data_classification.category_id | Recommended: The normalized identifier of the data classification category. | integer |
| metadata.data_classification.confidentiality_id | Recommended: The normalized identifier of the file content confidentiality indicator. | integer |
| metadata.event_code | Optional: The Event ID or Code that the product uses to describe the event. | string |
| metadata.log_level | Optional: The audit level at which an event was generated. | string |
| metadata.log_name | Recommended: The event log name. For example, syslog file name or Windows logging subsystem: Security. | string |
| metadata.log_provider | Recommended: The logging provider or logging service that logged the event. For example, Microsoft-Windows-Security-Auditing. | string |
| metadata.original_time | Recommended: The original event time as reported by the event source. | string |
| metadata.product | Required: The product that reported the event. | object |
| metadata.product.data_classification | Recommended: The Data Classification object includes information about data classification levels and data category types. | object |
| metadata.product.data_classification.category_id | Recommended: The normalized identifier of the data classification category. | integer |
| metadata.product.data_classification.confidentiality_id | Recommended: The normalized identifier of the file content confidentiality indicator. | integer |
| metadata.product.feature | Optional: The feature that reported the event. | object |
| metadata.product.feature.name | Recommended: The name of the feature. | string |
| metadata.product.feature.uid | Recommended: The unique identifier of the feature. | string |
| metadata.product.feature.version | Recommended: The version of the feature. | string |
| metadata.product.name | Recommended: The name of the product. | string |
| metadata.product.uid | Recommended: The unique identifier of the product. | string |
| metadata.product.vendor_name | Required: The name of the vendor of the product. | string |
| metadata.product.version | Recommended: The version of the product, as defined by the event source. For example: 2013.1.3-beta. |
string |
| metadata.profiles | Optional: The list of profiles used to create the event. | array of strings |
| metadata.sequence | Optional: Sequence number of the event. The sequence number is a value available in some events, to make the exact ordering of events unambiguous, regardless of the event time precision. | integer |
| metadata.tenant_uid | Recommended: The unique tenant identifier. | string |
| metadata.uid | Optional: The logging system-assigned unique identifier of an event instance. | string |
| metadata.version | Required: The version of the OCSF schema, using Semantic Versioning Specification. | string |
| num_detections | Recommended: The number of detections. | integer |
| num_files | Recommended: The number of files scanned. | integer |
| num_folders | Recommended: The number of folders scanned. | integer |
| num_network_items | Recommended: The number of network items scanned. | integer |
| num_processes | Recommended: The number of processes scanned. | integer |
| num_registry_items | Recommended: The number of registry items scanned. | integer |
| num_resolutions | Recommended: The number of items that were resolved. | integer |
| num_skipped_items | Recommended: The number of skipped items. | integer |
| num_trusted_items | Recommended: The number of trusted items. | integer |
| observables | Recommended: The observables associated with the event or a finding. | array of objects |
| observables.name | Required: The full name of the observable attribute. The name is a pointer/reference to an attribute within the event data. For example: file.name. |
string |
| observables.type | Optional: The observable value type name. | string |
| observables.type_id | Required: The observable value type identifier. | integer |
| observables.value | Optional: The value associated with the observable attribute. The meaning of the value depends on the observable type. | string |
| original_event_time | Required: The original event time from the source system. | long |
| policy | Recommended: The policy associated with this Scan event; required if the scan was initiated by a policy. | object |
| policy.name | Recommended: The policy name. For example: IAM Policy. |
string |
| policy.uid | Recommended: A unique identifier of the policy instance. | string |
| policy.version | Recommended: The policy version number. | string |
| proxy_connection_info | Recommended: The connection information from the proxy server to the remote server. | object |
| proxy_connection_info.direction | Optional: The direction of the initiated connection, traffic, or email, normalized to the caption of the direction_id value. | string |
| proxy_connection_info.direction_id | Required: The normalized identifier of the direction of the initiated connection, traffic, or email. | integer |
| proxy_connection_info.protocol_name | Optional: The TCP/IP protocol name in lowercase, as defined by the Internet Assigned Numbers Authority (IANA). | string |
| proxy_connection_info.protocol_num | Recommended: The TCP/IP protocol number, as defined by the Internet Assigned Numbers Authority (IANA). | integer |
| proxy_connection_info.session | Optional: The authenticated user or service session. | object |
| proxy_connection_info.session.created_time | Recommended: The time when the session was created. | long |
| proxy_connection_info.session.is_remote | Recommended: The indication of whether the session is remote. | boolean |
| proxy_connection_info.session.issuer | Recommended: The identifier of the session issuer. | string |
| proxy_connection_info.session.uid | Recommended: The unique identifier of the session. | string |
| proxy_connection_info.session.uuid | Optional: The universally unique identifier of the session. | string |
| proxy_connection_info.uid | Optional: The unique identifier of the connection. | string |
| proxy_tls | Recommended: The TLS protocol negotiated between the proxy server and the remote server. | object |
| proxy_tls.certificate | Recommended: The certificate object containing information about the digital certificate. | object |
| proxy_tls.certificate.created_time | Recommended: The time when the certificate was created. | long |
| proxy_tls.certificate.expiration_time | Recommended: The expiration time of the certificate. | long |
| proxy_tls.certificate.fingerprints | Required: The fingerprint list of the certificate. | array of objects |
| proxy_tls.certificate.fingerprints.algorithm | Optional: The hash algorithm used to create the digital fingerprint, normalized to the caption of 'algorithm_id'. | string |
| proxy_tls.certificate.fingerprints.algorithm_id | Required: The identifier of the normalized hash algorithm, which was used to create the digital fingerprint. | integer |
| proxy_tls.certificate.fingerprints.value | Required: The digital fingerprint value. | string |
| proxy_tls.certificate.issuer | Required: The certificate issuer distinguished name. | string |
| proxy_tls.certificate.serial_number | Required: The serial number of the certificate used to create the digital signature. | string |
| proxy_tls.certificate.subject | Recommended: The certificate subject distinguished name. | string |
| proxy_tls.certificate.version | Recommended: The certificate version. | string |
| proxy_tls.certificate_chain | Recommended: The Chain of Certificate Serial Numbers field provides a chain of Certificate Issuer Serial Numbers leading to the Root Certificate Issuer. | array of strings |
| proxy_tls.cipher | Recommended: The negotiated cipher suite. | string |
| proxy_tls.client_ciphers | Recommended: The client cipher suites that were exchanged during the TLS handshake negotiation. | array of strings |
| proxy_tls.ja3_hash | Recommended: The MD5 hash of a JA3 string. | object |
| proxy_tls.ja3_hash.algorithm | Optional: The hash algorithm used to create the digital fingerprint, normalized to the caption of 'algorithm_id'. | string |
| proxy_tls.ja3_hash.algorithm_id | Required: The identifier of the normalized hash algorithm, which was used to create the digital fingerprint. | integer |
| proxy_tls.ja3_hash.value | Required: The digital fingerprint value. | string |
| proxy_tls.ja3s_hash | Recommended: The MD5 hash of a JA3S string. | object |
| proxy_tls.ja3s_hash.algorithm | Optional: The hash algorithm used to create the digital fingerprint, normalized to the caption of 'algorithm_id'. | string |
| proxy_tls.ja3s_hash.algorithm_id | Required: The identifier of the normalized hash algorithm, which was used to create the digital fingerprint. | integer |
| proxy_tls.ja3s_hash.value | Required: The digital fingerprint value. | string |
| proxy_tls.sni | Recommended: The Server Name Indication (SNI) extension sent by the client. | string |
| proxy_tls.version | Required: The TLS protocol version. | string |
| proxy_traffic | Recommended: The network traffic refers to the amount of data moving across a network, from proxy to remote server at a given point of time. | object |
| proxy_traffic.bytes | Recommended: The total number of bytes (in and out). | long |
| proxy_traffic.bytes_in | Optional: The number of bytes sent from the destination to the source. | long |
| proxy_traffic.bytes_out | Optional: The number of bytes sent from the source to the destination. | long |
| proxy_traffic.chunks | Optional: The total number of chunks (in and out). | long |
| proxy_traffic.chunks_out | Optional: The number of chunks sent from the source to the destination. | long |
| proxy_traffic.packets | Recommended: The total number of packets (in and out). | long |
| proxy_traffic.packets_in | Optional: The number of packets sent from the destination to the source. | long |
| proxy_traffic.packets_out | Optional: The number of packets sent from the source to the destination. | long |
| query_info | Recommended: The query info object holds information related to data access within a datastore. | object |
| query_info.name | Recommended: The query name for a saved or scheduled query. | string |
| query_info.query_string | Required: A string representing the query code being run. | string |
| query_info.uid | Recommended: The unique identifier of the query. | string |
| raw_data | Optional: The raw event/finding data as received from the source. | string |
| raw_data_size | Optional: The size of the raw data which was transformed into an OCSF event, in bytes. | long |
| resources | Recommended: Details about resources that were affected by the activity/event. | array of objects |
| resources.data_classification | Recommended: The Data Classification object includes information about data classification levels and data category types. | object |
| resources.data_classification.category_id | Recommended: The normalized identifier of the data classification category. | integer |
| resources.data_classification.confidentiality_id | Recommended: The normalized identifier of the file content confidentiality indicator. | integer |
| resources.owner | Recommended: The identity of the service or user account that owns the resource. | object |
| resources.owner.account | Optional: The user's account or the account associated with the user. | object |
| resources.owner.account.name | Recommended: The name of the account (For example, GCP Account Name). | string |
| resources.owner.account.type | Optional: The account type, normalized to the caption of 'account_type_id'. | string |
| resources.owner.account.type_id | Recommended: The normalized account type identifier. | integer |
| resources.owner.account.uid | Recommended: The unique identifier of the account (For example, AWS Account ID). | string |
| resources.owner.domain | Optional: The domain where the user is defined. For example: the LDAP or Active Directory domain. | string |
| resources.owner.email_addr | Optional: The user's primary email address. | string |
| resources.owner.full_name | Optional: The full name of the person, as per the LDAP Common Name attribute (cn). | string |
| resources.owner.name | Recommended: The username. For example, janedoe1. |
string |
| resources.owner.org | Optional: Organization and org unit related to the user. | object |
| resources.owner.org.name | Recommended: The name of the organization. For example, Widget, Inc. | string |
| resources.owner.org.ou_name | Recommended: The name of the organizational unit, within an organization. For example, Finance, IT, R&D | string |
| resources.owner.org.uid | Recommended: The unique identifier of the organization. For example, its Active Directory or AWS Org ID. | string |
| resources.owner.risk_level | Optional: The risk level, normalized to the caption of the risk_level_id value. | string |
| resources.owner.type | Optional: The type of the user. For example, System, AWS IAM User, | string |
| resources.owner.type_id | Recommended: The account type identifier. | integer |
| resources.owner.uid | Recommended: The unique user identifier. | string |
| scan | Required: The Scan object describes characteristics of the scan job. | object |
| scan.name | Recommended: The administrator-supplied or application-generated name of the scan. | string |
| scan.type_id | Required: The type id of the scan. | integer |
| scan.uid | Recommended: The application-defined unique identifier assigned to an instance of a scan. | string |
| schedule_uid | Recommended: The unique identifier of the schedule associated with a scan job. | string |
| severity | Optional: The event severity, normalized to the caption of the severity_id value. | string |
| severity_id | Required: The normalized identifier of the event/finding severity. | integer |
| src_endpoint | Required: The endpoint that performed the activity on the target file. | object |
| src_endpoint.container | Recommended: The information describing an instance of a container. | object |
| src_endpoint.container.hash | Recommended: Commit hash of image created for docker or the SHA256 hash of the container. For example: 13550340a8681c84c861aac2e5b44.... |
object |
| src_endpoint.container.hash.algorithm | Optional: The hash algorithm used to create the digital fingerprint, normalized to the caption of 'algorithm_id'. | string |
| src_endpoint.container.hash.algorithm_id | Required: The identifier of the normalized hash algorithm, which was used to create the digital fingerprint. | integer |
| src_endpoint.container.hash.value | Required: The digital fingerprint value. | string |
| src_endpoint.container.image | Recommended: The container image used as a template to run the container. | object |
| src_endpoint.container.image.name | Recommended: The image name. For example: elixir. |
string |
| src_endpoint.container.image.uid | Required: The unique image ID. For example: 77af4d6b9913. |
string |
| src_endpoint.container.name | Recommended: The container name. | string |
| src_endpoint.container.size | Recommended: The size of the container image. | long |
| src_endpoint.container.uid | Recommended: The full container unique identifier for this instantiation of the container. For example: ac2ea168264a08f9aaca0dfc82ff3.... |
string |
| src_endpoint.domain | Optional: The name of the domain. | string |
| src_endpoint.hostname | Recommended: The fully qualified name of the endpoint. | string |
| src_endpoint.instance_uid | Recommended: The unique identifier of a VM instance. | string |
| src_endpoint.interface_name | Recommended: The name of the network interface (For example, eth2). | string |
| src_endpoint.interface_uid | Recommended: The unique identifier of the network interface. | string |
| src_endpoint.ip | Recommended: The IP address of the endpoint, in either IPv4 or IPv6 format. | string |
| src_endpoint.location | Optional: The geographical location of the endpoint. | object |
| src_endpoint.location.city | Recommended: The name of the city. | string |
| src_endpoint.location.continent | Recommended: The name of the continent. | string |
| src_endpoint.location.country | Recommended: The ISO 3166-1 Alpha-2 country code. | string |
| src_endpoint.location.lat | Optional: The geographical Latitude coordinate represented in Decimal Degrees (DD). | float |
| src_endpoint.location.long | Optional: The geographical Longitude coordinate represented in Decimal Degrees (DD). | float |
| src_endpoint.location.region | Optional: The alphanumeric code that identifies the principal subdivision (For example, province or state) of the country. | string |
| src_endpoint.mac | Optional: The Media Access Control (MAC) address of the endpoint. | string |
| src_endpoint.name | Recommended: The short name of the endpoint. | string |
| src_endpoint.namespace_pid | Recommended: If running under a process namespace (such as in a container), the process identifier within that process namespace. | integer |
| src_endpoint.owner | Recommended: The identity of the service or user account that owns the endpoint or was last logged into it. | object |
| src_endpoint.owner.account | Optional: The user's account or the account associated with the user. | object |
| src_endpoint.owner.account.name | Recommended: The name of the account (For example, GCP Account Name). | string |
| src_endpoint.owner.account.type | Optional: The account type, normalized to the caption of 'account_type_id'. | string |
| src_endpoint.owner.account.type_id | Recommended: The normalized account type identifier. | integer |
| src_endpoint.owner.account.uid | Recommended: The unique identifier of the account (For example, AWS Account ID). | string |
| src_endpoint.owner.domain | Optional: The domain where the user is defined. For example: the LDAP or Active Directory domain. | string |
| src_endpoint.owner.email_addr | Optional: The user's primary email address. | string |
| src_endpoint.owner.full_name | Optional: The full name of the person, as per the LDAP Common Name attribute (cn). | string |
| src_endpoint.owner.name | Recommended: The username. For example, janedoe1. |
string |
| src_endpoint.owner.org | Optional: Organization and org unit related to the user. | object |
| src_endpoint.owner.org.name | Recommended: The name of the organization. For example, Widget, Inc. | string |
| src_endpoint.owner.org.ou_name | Recommended: The name of the organizational unit, within an organization. For example, Finance, IT, R&D | string |
| src_endpoint.owner.org.uid | Recommended: The unique identifier of the organization. For example, its Active Directory or AWS Org ID. | string |
| src_endpoint.owner.risk_level | Optional: The risk level, normalized to the caption of the risk_level_id value. | string |
| src_endpoint.owner.type | Optional: The type of the user. For example, System, AWS IAM User. | string |
| src_endpoint.owner.type_id | Recommended: The account type identifier. | integer |
| src_endpoint.owner.uid | Recommended: The unique user identifier. | string |
| src_endpoint.port | Recommended: The port used for communication within the network connection. | integer |
| src_endpoint.proxy_endpoint | Optional: The network proxy information pertaining to a specific endpoint. For example, . | object |
| src_endpoint.proxy_endpoint.container | Recommended: The information describing an instance of a container. | object |
| src_endpoint.proxy_endpoint.container.hash | Recommended: Commit hash of image created for docker or the SHA256 hash of the container. For example: 13550340a8681c84c861aac2e5b.... |
object |
| src_endpoint.proxy_endpoint.container.hash.algorithm | Optional: The hash algorithm used to create the digital fingerprint, normalized to the caption of 'algorithm_id'. | string |
| src_endpoint.proxy_endpoint.container.hash.algorithm_id | Required: The identifier of the normalized hash algorithm, which was used to create the digital fingerprint. | integer |
| src_endpoint.proxy_endpoint.container.hash.value | Required: The digital fingerprint value. | string |
| src_endpoint.proxy_endpoint.container.image | Recommended: The container image used as a template to run the container. | object |
| src_endpoint.proxy_endpoint.container.image.name | Recommended: The image name. For example: elixir. |
string |
| src_endpoint.proxy_endpoint.container.image.uid | Required: The unique image ID. For example: 77af4d6b9913. |
string |
| src_endpoint.proxy_endpoint.container.name | Recommended: The container name. | string |
| src_endpoint.proxy_endpoint.container.size | Recommended: The size of the container image. | long |
| src_endpoint.proxy_endpoint.container.uid | Recommended: The full container unique identifier for this instantiation of the container. For example: ac2ea168264a08f9aaca0dfc82ff3.... |
string |
| src_endpoint.proxy_endpoint.hostname | Recommended: The fully qualified name of the endpoint. | string |
| src_endpoint.proxy_endpoint.instance_uid | Recommended: The unique identifier of a VM instance. | string |
| src_endpoint.proxy_endpoint.interface_name | Recommended: The name of the network interface (For example, eth2). | string |
| src_endpoint.proxy_endpoint.interface_uid | Recommended: The unique identifier of the network interface. | string |
| src_endpoint.proxy_endpoint.ip | Recommended: The IP address of the endpoint, in either IPv4 or IPv6 format. | string |
| src_endpoint.proxy_endpoint.name | Recommended: The short name of the endpoint. | string |
| src_endpoint.proxy_endpoint.namespace_pid | Recommended: If running under a process namespace (such as in a container), the process identifier within that process namespace. | integer |
| src_endpoint.proxy_endpoint.owner | Recommended: The identity of the service or user account that owns the endpoint or was last logged into it. | object |
| src_endpoint.proxy_endpoint.owner.account | Optional: The user's account or the account associated with the user. | object |
| src_endpoint.proxy_endpoint.owner.account.name | Recommended: The name of the account (For example, GCP Account Name). | string |
| src_endpoint.proxy_endpoint.owner.account.type | Optional: The account type, normalized to the caption of 'account_type_id'. | string |
| src_endpoint.proxy_endpoint.owner.account.type_id | Recommended: The normalized account type identifier. | integer |
| src_endpoint.proxy_endpoint.owner.account.uid | Recommended: The unique identifier of the account (For example, AWS Account ID). | string |
| src_endpoint.proxy_endpoint.owner.domain | Optional: The domain where the user is defined. For example: the LDAP or Active Directory domain. | string |
| src_endpoint.proxy_endpoint.owner.email_addr | Optional: The user's primary email address. | string |
| src_endpoint.proxy_endpoint.owner.full_name | Optional: The full name of the person, as per the LDAP Common Name attribute (cn). | string |
| src_endpoint.proxy_endpoint.owner.name | Recommended: The username. For example, janedoe1. |
string |
| src_endpoint.proxy_endpoint.owner.org | Optional: Organization and org unit related to the user. | object |
| src_endpoint.proxy_endpoint.owner.org.name | Recommended: The name of the organization. For example, Widget, Inc. | string |
| src_endpoint.proxy_endpoint.owner.org.ou_name | Recommended: The name of the organizational unit, within an organization. For example, Finance, IT, R&D | string |
| src_endpoint.proxy_endpoint.owner.org.uid | Recommended: The unique identifier of the organization. For example, its Active Directory or AWS Org ID. | string |
| src_endpoint.proxy_endpoint.owner.risk_level | Optional: The risk level, normalized to the caption of the risk_level_id value. | string |
| src_endpoint.proxy_endpoint.owner.type | Optional: The type of the user. For example, System, AWS IAM User. | string |
| src_endpoint.proxy_endpoint.owner.type_id | Recommended: The account type identifier. | integer |
| src_endpoint.proxy_endpoint.owner.uid | Recommended: The unique user identifier. | string |
| src_endpoint.proxy_endpoint.port | Recommended: The port used for communication within the network connection. | integer |
| src_endpoint.proxy_endpoint.svc_name | Recommended: The service name in service-to-service connections. | string |
| src_endpoint.proxy_endpoint.type_id | Recommended: The network endpoint type ID. | integer |
| src_endpoint.proxy_endpoint.uid | Recommended: The unique identifier of the endpoint. | string |
| src_endpoint.svc_name | Recommended: The service name in service-to-service connections. | string |
| src_endpoint.type_id | Recommended: The network endpoint type ID. | integer |
| src_endpoint.uid | Recommended: The unique identifier of the endpoint. | string |
| src_endpoint.zone | Optional: The network zone or LAN segment. | string |
| start_time | Recommended: The start time of the scan job. | long |
| status | Recommended: The event status, normalized to the caption of the status_id value. | string |
| status_code | Recommended: The event status code, as reported by the event source. | string |
| status_detail | Recommended: The status details contains additional information about the event/finding outcome. | string |
| status_id | Recommended: The normalized identifier of the event status. | integer |
| table | Recommended: The table object represents a table within a structured relational database or datastore, which contains columns and rows of data that are able to be create, updated, deleted and queried. | object |
| table.name | Recommended: The table name, ordinarily as assigned by a database administrator. | string |
| table.uid | Recommended: The unique identifier of the table. | string |
| timezone_offset | Recommended: The number of minutes that the reported event time is ahead or behind UTC, in the range -1,080 to +1,080. |
integer |
| total | Recommended: The total number of items that were scanned; zero if no items were scanned. | integer |
| type_id | Recommended: The normalized datastore resource type identifier. | integer |
| type_name | Optional: The event type name, as defined by the type_uid. | string |
| type_uid | Required: The event/finding type ID. It identifies the event's semantics and structure. | long |
| unmapped | Optional: The attributes that are not mapped to the event schema. | object |
| volume | Required: The allocated event volume for the event in bytes. | long |
| web_resources | Required: Describes details about web resources that were affected by an activity/event. | array of objects |
| web_resources.data_classification | Recommended: The Data Classification object includes information about data classification levels and data category types. | object |
| web_resources.data_classification.category_id | Recommended: The normalized identifier of the data classification category. | integer |
| web_resources.data_classification.confidentiality_id | Recommended: The normalized identifier of the file content confidentiality indicator. | integer |
| web_resources.url_string | Recommended: The URL pointing towards the source of the web resource. | string |
| web_resources_result | Recommended: The results of the activity on web resources. | array of objects |
| web_resources_result.data_classification | Recommended: The Data Classification object includes information about data classification levels and data category types. | object |
| web_resources_result.data_classification.category_id | Recommended: The normalized identifier of the data classification category. | integer |
| web_resources_result.data_classification.confidentiality_id | Recommended: The normalized identifier of the file content confidentiality indicator. | integer |
| web_resources_result.url_string | Recommended: The URL pointing towards the source of the web resource. | string |